user_mobilelogo
Welcome, Guest
Username: Password: Remember me
This is a public forum thread open to all users
  • Page:
  • 1

TOPIC:

fuse problem 10 years 11 months ago #31322

Hi all, as tou may or may not know I am a new hen in this here X1/9 coup and I need a mother hens help here. My courtesy lights, cigar lighter, radio and aerial dos not work. I have consulted the manual and it says its a 20amp fuse second row down and 4th from the left marked as "L" in the manual. I have swapped fuses and still no joy, can anyone help. Oh, and whilst I'm on the subject of fuse boxes, is there an art to getting the fuse box tray quick release bolts to quickly relocate into the holes. Thanks. Paul.

Please Log in or Create an account to join the conversation.

fuse problem 10 years 11 months ago #31324

I assume the fuse you removed was blown, if not you might have the wrong fuse - an easy mistake. I had similar issues trying to get the tray back up and I found if you use a stubby screw driver to push the fixings straight up they will click into place. As you have found out you have to turn them to get then to release

Please Log in or Create an account to join the conversation.

fuse problem 10 years 11 months ago #31326

Hi Jonathan, thanks for the reply. I cannot tell if its blown on the blade fuses, but everything else is working and that's the one that the manual says it should be. I was wondering if it is one of the relays. I cant see it being a wiring fault as the wiring would need to be faulty on three separate things. Paul.

Please Log in or Create an account to join the conversation.

fuse problem 7 months 2 weeks ago #43434

Did you sort this out as I have exactly the same problem with my 1984 X1/9.

My courtesy lights are not working, my radio and auto aerial are not working and my cigarette lighter isn’t working. Can’t see clearly which fuse has blown if any at all

Please Log in or Create an account to join the conversation.

fuse problem 7 months 2 weeks ago #43436

Ok, As Speedy says the way I used was that - just push up on the brass screwhead and they should just click in place.
Fuse: the one marked Services and a cigarette 20Amp is the correct fuse on the later mini blade fuse box.
I checked the circuit diagrams and it appears straightforward -
If you look at the fuse carefully under good light it should be obvious when it is blown.

Did I read you do not have a courtesy light timer module to hold the lights on for some seconds?

Please Log in or Create an account to join the conversation.

fuse problem 5 months 3 weeks ago #43557

Did you solve this as I also have the same prob and the 20amp fuse is ok!

Please Log in or Create an account to join the conversation.

fuse problem 5 months 3 weeks ago #43567

  • NRG
  • NRG's Avatar
  • Offline
  • Elite Member
  • Elite Member
  • Posts: 302
  • Thank you received: 101
10yr old thread!

Please Log in or Create an account to join the conversation.

fuse problem 5 months 3 weeks ago #43568

And? I was replying to a post put on here a month ago...

Please Log in or Create an account to join the conversation.

fuse problem 5 months 3 weeks ago #43570

This was a problem with my car. The fix was the inline fuse near the fuse box that had blown
The following user(s) said Thank You: Alan Hutton

Please Log in or Create an account to join the conversation.

  • Page:
  • 1
Time to create page: 0.059 seconds