user_mobilelogo
Welcome, Guest
Username: Password: Remember me
This is a public forum thread open to all users
  • Page:
  • 1

TOPIC: Exey is having a 'moment'

Exey is having a 'moment' 5 months 1 week ago #39697

I think the Fiat is trying to tell me something.

Took her into work today, started fine, warmed up ok, ran as well as ever through the early morning mist.

Then I glanced down and the temp gauge was right at the top. A moment of panic and then it dropped to halfway, before flicking instantly back to max, down to halfway again, then back to max and staying there.

The car was running ok, no smells, no smoke or steam, not down on power, no funny noises so I pressed on.

Then I noticed that the fuel gauge was reading empty but the idiot light wasn't on. I know for a fact that there is at least a 1/4 of a tank in there.

The funny thing is, I currently have three cars on the road, the Fiat, an MGF and a 1999 Alfa 156 V6. All three of them are currently experiencing temp gauge issues. What are the chances of that?!

Is there a common electrical link between the temp & fuel gauges? Do they share a fuse or anything?

Please Log in or Create an account to join the conversation.

Exey is having a 'moment' 5 months 1 week ago #39699

I don't think there is a common electrical link between the two.

I had similar temp gauge issues with my old car, unfortunately there was an airlock in the system after having a new radiator fitted, it resulted in a blown head gasket. Hopefully you have better luck than I did though.

The fuel gauge could be a poor connection on the sender unit, mine does exactly the same thing and only works properly when over half full, when the float brings the broken connection together. Fill the car with fuel and see if it is the same problem, if so I think it is a fairly easy fix that can be done with out removing the tank, just the sender unit. I keep meaning to do mine but I don't seem to be able to find the time at the moment.

Please Log in or Create an account to join the conversation.

Exey is having a 'moment' 5 months 1 week ago #39714

Thanks John, I had a look over the weekend at her. The fuel gauge connections are all ok so I took her for a spin and put £20 in. And the fuel gauge reads fine. I'll keep a can of fuel in the boot and see if the idiot light is working or not.

The temp gauge also seems ok now. Bloody thing, just testing that I'm awake and paying attention!

Please Log in or Create an account to join the conversation.

Exey is having a 'moment' 5 months 6 days ago #39728

Fiats always had dodgy reading senders
Fill her up and first half of tank goes slow
Second half seems to get you searching for a filling station

As previously mentioned, poor/ corroded/contaminated earths usually responsible.
As for sender/readings, older sensors succumb to condensation and, although you can extend their life by periodically removing and spraying liberally with WD40/AC90, it’s time to replace as removal requires a new seal anyway

Please Log in or Create an account to join the conversation.

Strike 2....strike one for resto

Exey is having a 'moment' 5 months 5 days ago #39744

Used the Fiat for work today, at 6am I went outside to start her up and she burst into life first time (as she always does). And the temp gauge went straight to max! She was absolutely fine on the 50 minute drive in, no smells, no steam, heater working fine, no loss of power, no hesitation. Just the temp gauge reading max all the way.

I've just ordered a new sender.

Please Log in or Create an account to join the conversation.

  • Page:
  • 1
Time to create page: 0.119 seconds