user_mobilelogo
Welcome, Guest
Username: Password: Remember me
This is a public forum thread open to all users
  • Page:
  • 1

TOPIC: What a shame !

What a shame ! 1 year 3 months ago #40372



I bought my latest X back in November and have been working every weekend on getting it running right . I finished the engine this morning after bolting the last few bits back on and thought I would go for my first ever drive in it on such a beautiful day. Took the roof off, went to start it and battery was dead. Ok I’ll charge it , I thought, 4 hours later and the battery is still flat and 100% dead. Ordering a new one now, but on such a glorious day, what a shame.
Engine bay picture attached.
Attachments:

Please Log in or Create an account to join the conversation.

What a shame ! 1 year 3 months ago #40376

Such a shame! & so annoying!
If you don't have one, a CTEK charger is a really good investment for a car that's used that often and stored through the winter.
The following user(s) said Thank You: Andy Giddings

Please Log in or Create an account to join the conversation.

What a shame ! 1 year 3 months ago #40379

I never leave my X without disconnecting the battery

Please Log in or Create an account to join the conversation.

What a shame ! 1 year 3 months ago #40388

Optimate is good too.
Live and let live.
The following user(s) said Thank You: Andy Giddings

Please Log in or Create an account to join the conversation.

What a shame ! 1 year 2 months ago #40439

That's a tidy engine :-)

Please Log in or Create an account to join the conversation.

  • Page:
  • 1
Time to create page: 0.106 seconds